Прекращение поддержки версии 5.6

Дата:
Автор: admin
Категория: cms concrete5, сообщество concrete5

Пользователям concrete5 наверняка известно, что в истории версий cms есть большой скачок, имеющий несовместимость версий. В течение пяти лет для обновления concrete5 достаточно было нажать кнопку «Обновить» в разделе администрирования, чтобы перейти от версии 5.1 до 5.2, до 5.3 и так далее до 5.6 включительно.

Затем вышла «Версия 7», которая была довольно глубоко переписана, чтобы соответствовать современным стандартам PHP. Разработчики ядра создали инструменты миграции, но на самом деле это был процесс создания нового сайта и добавления в него старого контента. С тех пор мы отбросили первую цифру «5» из номера версии и поработали над тем, чтобы волшебная кнопка обновления работала так же как и раньше. Мы надеемся, что больше никогда не придётся выпускать обратно несовместимую версию.

Всё это происходило в период с 2014 по 2015 годы. В то же время разработчики ядра пообещали, что будут поддерживать версии 6-го семейства cms с точки зрения безопасности до тех пор пока не поступит новое уведомление. Мы понимаем, что до сих пор существуют важные сайты всё ещё использующие версии 5.6.X и потребуется время, чтобы построить последовательную стратегию по перестроению сайта. Мы знаем, что владельцу сайта было бы важно получить предупреждение заранее, а так же предоставить конкретный день, когда начнётся обратный отсчёт, а за это время владелец сайта смог бы распланировать все действия с сайтом.

Итак, этот волшебный день настал!

Разработчики ядра concrete5 официально объявили об окончании работы версии 6. В течение последующих 12 месяцев если станет известно о серьёзной проблеме безопасности в cms 6-го поколения, то эти баги будут немедленно исправлены. Но после 24 августа 2019 разработчики ядра вообще не будут поддерживать версию 6.

Возможно вы заметили, что на официальном сайте concrete5.org разработчики ядра опубликовали все свои дополнения для cms 6-го поколения бесплатно. Поскольку продавать расширения для продукта, который не будет поддерживаться, не имеет смысла. Продажа модулей для устаревшей версии cms в магазине дополнений будет прекращена 22 ноября 2018 года. Поддержка будет продолжать работать в течение последующих 90 дней. После этого магазин дополнений для concrete5 версий 5.6 и ниже будет полностью удалён.

Прошло более 3 лет с тех пор, как разработчики оставили версию 5.6 позади и перестали над ней активно работать. На данный момент частично уже ведётся разработка над 9-ой версией concrete5. Впереди большие дела, есть над чем работать и эта работа должна быть ориентирована на будущее. Спасибо за понимание!

Другие новости

Продолжая просматривать сайт, вы даёте согласие на использование файлов cookie.

Подробнее